3.0.2 - Comment Settings ignored

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
User avatar
Connie
Posts: 1169
Joined: 10 Nov 2009, 04:53
Contact:

3.0.2 - Comment Settings ignored

Post by Connie » 06 Dec 2009, 00:23

Hi!

I just installed version 3.0.2 and I notice that even when the article settings define that no comments and trackbacks are active, the singlepage shows the comment-form

I set all options in the comment-section to "hide" and I hide all comments-links as well

I also disabled to show the texts "no comments at this time ... " when commenting is closed, but the text is shown...

If this is a bug, I hope it can be fixed soon and easily, have a nice sunday!

Connie

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by sayontan » 06 Dec 2009, 01:16

Connie,
That doesn't seem to be the case - I checked for both, posts and pages. See this post: http://www.aquoid.com/news/2009/08/anno ... een-light/ and this page: http://www.aquoid.com/news/themes/suffusion/ . Both have comments disabled and the second page has the "Comments closed" text hidden. The behavior is as you would expect. As you can guess, I am on version 3.0.2 myself.

Sayontan.

User avatar
Connie
Posts: 1169
Joined: 10 Nov 2009, 04:53
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by Connie » 06 Dec 2009, 02:36

Sayontan, thank you for caring:

Where to disable the ""Sorry, the comment form is closed at this time." -text? I do not find that in the moment...
I only find where to disable it for pages, not for posts.... :roll:

The comment-links etc. are still shown on the single-post-page .. have a look there

here are my settings:

the post has not allowed trackbacks and comments, checkboxes are unchecked

Theme Options / Comment Settings:
Hide "Comment form closed" Message on Pages => checked at the about article
Show Trackbacks and Pingbacks? => Don't show Trackbacks and Pingbacks
Allow Replies for Trackbacks and Pingbacks? => Don't allow replies to Trackbacks and Pingbacks
Comment form labels styles => Theme-based style

Theme Options / Post and Pages:
Show Comments link for Posts? => Hide Comments link
Show Comments link for Pages? => Hide Comments link

and in Settings / Discussion:
Default settings: Don't allow users to comment new articles, all settings here are unchecked

the posts have no checked checkboxes

I cleared the cache, logged out and in WP, but still the links are shown
Attachments
comment_2.jpg
Result in SinglePage-View
comment_2.jpg (10.94 KiB) Viewed 11188 times
comment_1.jpg
Post-Settings
comment_1.jpg (243.86 KiB) Viewed 11188 times

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by sayontan » 06 Dec 2009, 11:49

What is your blog's address? Is it http://www.bildgier.de/?lang=en ? Are you referring to the "Add Comments" link in the single post view? There was a bug that I fixed in 3.0.5 (submitted for approval, not yet released), which causes this to happen for posts, not for pages.

Currently there is no option disable the "Sorry, the comment form is closed" message for posts. I can add that.

User avatar
Connie
Posts: 1169
Joined: 10 Nov 2009, 04:53
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by Connie » 07 Dec 2009, 05:42

Hi, no that blog is not the blog I am working on, that is a test for my nephew...

I am currently transferring an old nucleus-blog to WP and I do this locally, so I cannot show you.
Whenever you see a posting in single mode, you see "Add Comments.." , this bug will be fixed, you say. That is good.

But I think to disable the text "Sorry, the commentform is closed" as an option is really a good idea, as there are blogs with no comments at all, and then this text ist without meaning, has the same importance like any random text "sorry there is no cheese on the pizza" :lol:

Please add that as an option!

Cheers, Connie

User avatar
Connie
Posts: 1169
Joined: 10 Nov 2009, 04:53
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by Connie » 08 Dec 2009, 03:24

Hi!

The bug with "add comment here" even when comments are disabled is fixed in 3.0.5
Thanks for that!

So it's just leaving open the option to not display the hint "comments are closed"...

I am optimistic. Have a nice day!

Connie

mjsumner
Posts: 1
Joined: 09 Dec 2009, 09:20

3.0.5 - Comment Settings ignored

Post by mjsumner » 09 Dec 2009, 09:26

Hi there,

Love the theme and thanks for adding the option to get rid of the "Sorry, the comment form is closed" notification...
However, I only seem to be able to hide it on my home page, even though I have disabled comments on the other pages I have selected to hide the notification: http://bridgecf.org/wp/

I am on the latest release on your theme.
Many many thanks!
Michael :)

User avatar
Connie
Posts: 1169
Joined: 10 Nov 2009, 04:53
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by Connie » 09 Dec 2009, 14:43

Michael, you mix apples with pears...

the "add comment here" will not show up when commenting is disabled

but the message "the comment form is closed" is still visible, that option will be included, Sayontan promised, but it is not done yet.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: 3.0.2 - Comment Settings ignored

Post by sayontan » 09 Dec 2009, 17:46

Michael,
Not really sure what you are asking. To disable the "Comments are Closed" message at the bottom of the page, you have to go to "Comment Settings", then 'Hide "Comment form closed" Message on Pages' and select the pages for which you want to hide this information. Have you done that?

Sayontan.

EOSF
Posts: 8
Joined: 13 Nov 2009, 16:48

Re: 3.0.2 - Comment Settings ignored

Post by EOSF » 09 Dec 2009, 19:10

Sayontan,
I seam to have the same problem as Michael, but only on pages made after the 3.0.5 upgrade. Yes, "Hide" is checked.

Also, found a typo here:

If you disable comments on a page, by default a "Comment form closed" message shows up. You can choose to hide this message for selected pages, if you thing it makes your page look too "blog-like". If you select a page from the list below it will not show the "Comment form closed" message. Note that if comments are enabled for a page, selecting it here will not make a difference.

Locked