Fatal Error after upgrading to 3.6.3

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Fatal Error after upgrading to 3.6.3

Post by sayontan » 20 Nov 2010, 03:40

Interesting. It used to work earlier, when the JS was in the header only, but now it works only if translator is explicitly in the footer. Thanks.

If you want to fix this, you can go to actions.php, then search for the function suffusion_include_google_translate_js. Look for this line:

Code: Select all

	    wp_register_script('google-translate', 'http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit', array(), null, $footer);
Change it to:

Code: Select all

	    wp_register_script('google-translate', 'http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit', array(), null, true);

eliz
Posts: 11
Joined: 18 Jun 2010, 03:38
Location: Romania
Contact:

Re: Fatal Error after upgrading to 3.6.3

Post by eliz » 20 Nov 2010, 09:57

the fix is working

Locked