update for start_el function

Reports about issues that you encounter in Suffusion
Forum rules
1. No offensive language and no mocking
2. Please do a thorough search before you post something. Trust us, there is a high probability that the question you are asking has been asked previously.
3. No soliciting. You cannot post here soliciting bids for people offer you quotes, or even offer money to people for some work. You will be moderated if you do so. If you are looking for help, please post your request on http://jobs.wordpress.net or http://codepoet.com
4. Please be reasonable. You are getting software and support. For free. Complicated requests from a general purpose theme are not welcome and some volunteers might lose patience with you.
5. Please do your due diligence. If you posted a query and we answered with a link, take the trouble to go through the link contents.
6. Please post with complete information. Requests for help MUST be accompanied with your URL, particularly if you are asking something like "Why am I seeing a blank space?"

update for start_el function

Postby dvl » 02 Aug 2013, 08:36

After upgrading to WordPress 3.6, I started seeing these errors when using Suffusion 4.4.6:

Code: Select all
Strict Standards: Declaration of Suffusion_MM_Walker::start_el() should be compatible with
Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in
/var/www/wordpress/themes/suffusion.4.4.6/library/suffusion-walkers.php on line 39


Solution: update library/suffusion-walkers.php on line 17 to:

Code: Select all
function start_el( &$output, $item, $depth = 0, $args = array(), $id = 0 ) {


More information here: http://dan.langille.org/2013/08/02/word ... de-issues/

Hope that helps. Thank you.
dvl
 
Posts: 3
Joined: 02 Aug 2013, 08:32

Re: update for start_el function

Postby dvl » 02 Aug 2013, 10:44

FYI, I found two other similar issues, and added the details to my blog post.
dvl
 
Posts: 3
Joined: 02 Aug 2013, 08:32

Re: update for start_el function

Postby sayontan » 02 Aug 2013, 17:49

Thanks - I will address this in 4.4.8. When do you see this issue, though?
Sayontan Sinha | http://mynethome.net/blog | http://www.aquoid.com/news
I don't do freelance work (for Suffusion or otherwise), so please don't contact me for quotes or offers.
sayontan
Site Admin
 
Posts: 10168
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas

Re: update for start_el function

Postby dvl » 04 Aug 2013, 13:18

I just upgraded to 4.4.7. I see these messages on every page.

HTH
dvl
 
Posts: 3
Joined: 02 Aug 2013, 08:32

Re: update for start_el function

Postby drake » 20 Jul 2014, 18:20

@Sarah - you've already quoted the solution in your post, as the first post of @dvl contain this solution. Make the changes if you wish... But, if your site don't works, is not because of these warnings. They are just warnings, they don't break anything. If you set WP_DEBUG to "false" in wp-config.php should not see any of these warnings.

Anyway, if you upgrade WordPress to any version above 3.6., is required to update Suffusion to 4.4.7. otherwise Save/Reset option button will not works (see the post from the top of forum)
drake
 
Posts: 5564
Joined: 26 Jul 2011, 07:56
Location: Constanta, Romania


Return to Bug Reports

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests