Page 1 of 1

update for start_el function

Posted: 02 Aug 2013, 08:36
by dvl
After upgrading to WordPress 3.6, I started seeing these errors when using Suffusion 4.4.6:

Code: Select all

Strict Standards: Declaration of Suffusion_MM_Walker::start_el() should be compatible with 
Walker::start_el(&$output, $object, $depth = 0, $args = Array, $current_object_id = 0) in 
/var/www/wordpress/themes/suffusion.4.4.6/library/suffusion-walkers.php on line 39
Solution: update library/suffusion-walkers.php on line 17 to:

Code: Select all

function start_el( &$output, $item, $depth = 0, $args = array(), $id = 0 ) {
More information here: http://dan.langille.org/2013/08/02/word ... de-issues/

Hope that helps. Thank you.

Re: update for start_el function

Posted: 02 Aug 2013, 10:44
by dvl
FYI, I found two other similar issues, and added the details to my blog post.

Re: update for start_el function

Posted: 02 Aug 2013, 17:49
by sayontan
Thanks - I will address this in 4.4.8. When do you see this issue, though?

Re: update for start_el function

Posted: 04 Aug 2013, 13:18
by dvl
I just upgraded to 4.4.7. I see these messages on every page.

HTH

Re: update for start_el function

Posted: 20 Jul 2014, 18:20
by drake
@Sarah - you've already quoted the solution in your post, as the first post of @dvl contain this solution. Make the changes if you wish... But, if your site don't works, is not because of these warnings. They are just warnings, they don't break anything. If you set WP_DEBUG to "false" in wp-config.php should not see any of these warnings.

Anyway, if you upgrade WordPress to any version above 3.6., is required to update Suffusion to 4.4.7. otherwise Save/Reset option button will not works (see the post from the top of forum)