Comments Location Bug (small issue)

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Locked
vlsh
Posts: 14
Joined: 09 Sep 2010, 12:26

Comments Location Bug (small issue)

Post by vlsh » 08 Nov 2010, 12:21

With new suffusion 3.6.8,
setting location of comments on the bottom of the posts does not show up, they do show up at the top though. This small issue is is only occurs on "front page." Clicking on the individual post the comments box still shows up fine.

I'm also using the excerpts setting for previous posts, the first post is a full display.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Comments Location Bug (small issue)

Post by sayontan » 08 Nov 2010, 12:22

I am aware of this issue - I should have a fix ready by evening.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Comments Location Bug (small issue)

Post by sayontan » 08 Nov 2010, 13:41

Here is the fix:
1. Go to Appearance -> Editor and open the file actions.php
2. Look for the function suffusion_post_footer()
3. The second line in the function is:

Code: Select all

	if ((is_page() && $suf_page_information_location != 'pullout') || (!is_page() && is_singular() && $suf_post_information_location != 'pullout')) {
Either comment this line (by putting // in the beginning) or delete it
4. Near the end of this function you will see:

Code: Select all

<?php
	}
?>
		</div>
<?php
	}
}
Change it to:

Code: Select all

<?php
	}
?>
		</div>
<?php
//	}
}
5. Save the file.

That should fix it.

vlsh
Posts: 14
Joined: 09 Sep 2010, 12:26

Re: Comments Location Bug (small issue)

Post by vlsh » 09 Nov 2010, 18:57

worked like a charm, thank you sir

Redwebtoo
Posts: 5
Joined: 11 Nov 2010, 06:19

Re: Comments Location Bug (small issue)

Post by Redwebtoo » 11 Nov 2010, 06:45

Excellent, fixed the problem for me too :D
thank you

Locked