Page 1 of 1

Comments Location Bug (small issue)

Posted: 08 Nov 2010, 12:21
by vlsh
With new suffusion 3.6.8,
setting location of comments on the bottom of the posts does not show up, they do show up at the top though. This small issue is is only occurs on "front page." Clicking on the individual post the comments box still shows up fine.

I'm also using the excerpts setting for previous posts, the first post is a full display.

Re: Comments Location Bug (small issue)

Posted: 08 Nov 2010, 12:22
by sayontan
I am aware of this issue - I should have a fix ready by evening.

Re: Comments Location Bug (small issue)

Posted: 08 Nov 2010, 13:41
by sayontan
Here is the fix:
1. Go to Appearance -> Editor and open the file actions.php
2. Look for the function suffusion_post_footer()
3. The second line in the function is:

Code: Select all

	if ((is_page() && $suf_page_information_location != 'pullout') || (!is_page() && is_singular() && $suf_post_information_location != 'pullout')) {
Either comment this line (by putting // in the beginning) or delete it
4. Near the end of this function you will see:

Code: Select all

<?php
	}
?>
		</div>
<?php
	}
}
Change it to:

Code: Select all

<?php
	}
?>
		</div>
<?php
//	}
}
5. Save the file.

That should fix it.

Re: Comments Location Bug (small issue)

Posted: 09 Nov 2010, 18:57
by vlsh
worked like a charm, thank you sir

Re: Comments Location Bug (small issue)

Posted: 11 Nov 2010, 06:45
by Redwebtoo
Excellent, fixed the problem for me too :D
thank you