Missing Comment Reply with Social Plugin

Reports about issues that you encounter in Suffusion
Forum rules
1. No offensive language and no mocking
2. Please do a thorough search before you post something. Trust us, there is a high probability that the question you are asking has been asked previously.
3. No soliciting. You cannot post here soliciting bids for people offer you quotes, or even offer money to people for some work. You will be moderated if you do so. If you are looking for help, please post your request on http://jobs.wordpress.net or http://codepoet.com
4. Please be reasonable. You are getting software and support. For free. Complicated requests from a general purpose theme are not welcome and some volunteers might lose patience with you.
5. Please do your due diligence. If you posted a query and we answered with a link, take the trouble to go through the link contents.
6. Please post with complete information. Requests for help MUST be accompanied with your URL, particularly if you are asking something like "Why am I seeing a blank space?"

Missing Comment Reply with Social Plugin

Postby GilesFarrow » 17 Dec 2011, 06:35

I am using Suffusion theme, after installing Social plugin (by MailChimp) the reply option on comments disappears.

It's there with several other themes.
It's there if I deactivate Social.
I have also deactivated all other plugins.

I don't think it is a CSS issue as the HTML for "reply" is not there.

So I am guessing it's an incompatibility between Social and Suffusion PHP. I'm not sure how best to proceed


I also posted this on the forum for the Social plugin http://wordpress.org/support/topic/plugin-social-missing-comment-reply-with-suffusion-theme

Any help or suggestions please?
GilesFarrow
 
Posts: 4
Joined: 17 Dec 2011, 06:26

Re: Missing Comment Reply with Social Plugin

Postby sayontan » 17 Dec 2011, 10:41

When I look at your page in Firebug console I see these errors:

Code: Select all
uncaught exception: Error: Permission denied for <http://www.facebook.com> to get property Proxy.InstallTrigger
uncaught exception: Error: Permission denied for <http://platform.twitter.com> to get property Proxy.InstallTrigger
uncaught exception: Error: Permission denied for <http://platform.twitter.com> to get property Proxy.InstallTrigger


These are definitely not from the theme and my guess is they are from the plugin (they are all "social"). I don't know why they come or how you have to fix it, though.
Sayontan Sinha | http://mynethome.net/blog | http://www.aquoid.com/news
I don't do freelance work (for Suffusion or otherwise), so please don't contact me for quotes or offers.
sayontan
Site Admin
 
Posts: 10168
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas

Re: Missing Comment Reply with Social Plugin

Postby GilesFarrow » 17 Dec 2011, 11:39

Thank you very much Sayontan, this gives me an angle to investigate

I will update here, if I find an answer
GilesFarrow
 
Posts: 4
Joined: 17 Dec 2011, 06:26

Re: Missing Comment Reply with Social Plugin

Postby GilesFarrow » 17 Dec 2011, 12:17

I found what was causing the uncaught exceptions.
I had some custom PHP in my child theme.

Not using the child theme now
- uncaught error messages are gone
- but reply for comments is still missing

http://gilesfarrow.co.uk/2011/this-site-is-for-testing/#comment-28

Any suggestions for what else I can do / look at ?
GilesFarrow
 
Posts: 4
Joined: 17 Dec 2011, 06:26

Re: Missing Comment Reply with Social Plugin

Postby sayontan » 17 Dec 2011, 12:32

Sorry, I don't really know. Since you say that the HTML markup is not being printed, I believe it has something to do with a hook being used. But I have never worked with this plugin, so I don't know what hook if any needs to be included.
Sayontan Sinha | http://mynethome.net/blog | http://www.aquoid.com/news
I don't do freelance work (for Suffusion or otherwise), so please don't contact me for quotes or offers.
sayontan
Site Admin
 
Posts: 10168
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas

Re: Missing Comment Reply with Social Plugin

Postby GilesFarrow » 02 Jan 2012, 17:17

I found a solution by changing a setting in Suffusion Options

Back-end > Comment Settings > Allow Replies for Trackbacks and Pingbacks?
set to Allow replies to Trackbacks and Pingbacks

If this is set then Comments keep the Reply option

I guess the way Social plugin treats comments is treated by Suffusion as being Trackbacks / Pingbacks
GilesFarrow
 
Posts: 4
Joined: 17 Dec 2011, 06:26


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests

cron