Page 1 of 2

Featured Posts not showing

PostPosted: 16 Nov 2009, 13:55
by marcnyc
I have enabled the featured posts on the default page but don't see them... am I doing something wrong or missing something?

Re: Featured Posts not showing

PostPosted: 16 Nov 2009, 14:42
by sayontan
What are the inclusions you have set for your featured posts? Is it supposed to pick up sticky posts and / or some categories? I have this condition set for displaying featured posts:

Code: Select all
   if ((is_category() && $suf_featured_category_view == "enabled") ||
      (is_tag() && $suf_featured_tag_view == "enabled") ||
      (is_search() && $suf_featured_search_view == "enabled") ||
      (is_author() && $suf_featured_author_view == "enabled") ||
      ((is_date() || is_year() || is_month() || is_day() || is_time()) && $suf_featured_time_view == "enabled") ||
      (!(is_category() || is_tag() || is_search() || is_author() || is_date() || is_year() || is_month() || is_day() || is_time()) && $suf_featured_index_view == "enabled")) {


I am guessing your page should satisfy the last condition in the above, unless it is somehow not doing so.

Re: Featured Posts not showing

PostPosted: 16 Nov 2009, 16:26
by marcnyc
I have not picked any posts anywhere, am I supposed to do that? where?
I thought that if I enable the feature I will just see the latest 10 posts as featured, is that not so? can it be so?

Re: Featured Posts not showing

PostPosted: 16 Nov 2009, 16:44
by sayontan
Well, Featured Posts are defined by what you declare as "featured". Typically people either mark their posts sticky (less followed practice) or assign a special category to such posts, called "Featured". I went a step ahead and let the users pick any of their categories to show as featured. That being said, it was just pointed out that I broke this functionality in the last release: viewtopic.php?f=4&t=135 .

What you are describing is more of a "latest posts" thing rather than "featured posts".

Re: Featured Posts not showing

PostPosted: 16 Nov 2009, 17:48
by marcnyc
is there a latest post solution available?

Re: Featured Posts not showing

PostPosted: 11 Dec 2009, 04:00
by owen
Hello,
I am having this same problem. (My pages aren't showing up). Has it been fixed in the most recent release?

Thanks!
Owen

Re: Featured Posts not showing

PostPosted: 11 Dec 2009, 05:53
by miguael
My featured posts aren't showing as well... can you point me in the right direction? I picked a certain category, and I don't use the sticky posts. But still nothing shows up - just the empty "space" of the featured box.
Could that be a conflict because I am using WPMU?
Would be great to have a hint.
PS: Your theme is GREAT and I think just what I was searching for a long time and those big WPMU Projects! Thanks!

ALL posts are showing up as featured

PostPosted: 11 Dec 2009, 06:12
by migf1
I have the kinda opposite problem. It shows all the posts in the featured area even when I do not mark them as sticky or using any featured image in them.

The same thing happens both in version 3.0.5 and 3.0.6: for 3.0.5 I tested it both with a clean install and via upgrading from 2.0.5, while for 3.0.6 I only tested it by upgrading from version 3.0.5

I'm using Wordpress 2.8.6

I'm supplying some screen shots of just one post which is not supposed to show up in the featured content area of the frontpage.

1. The global Featured Content settings of the theme
Image


2. The post with NO featured data attached to it
Image


3. The post shows up nevertheless in the featured content area in the frontpage
Image


Same thing happens to ALL my posts. Any help would be greatly appreciated.

Thanks in advance!

PS. For pages everything works good, using the "featured image" field.

Re: Featured Posts not showing

PostPosted: 11 Dec 2009, 09:14
by sayontan
Owen and Miguael,
Can you provide the URLs for your sites?

Sayontan.

Re: Featured Posts not showing

PostPosted: 11 Dec 2009, 09:20
by sayontan
Migf1,
This is a bug. It seems like all categories are retrieved when none is selected. I will fix it.

Sayontan.