Page 2 of 2

Re: Photonic Issue on Wordpress 4.3.1

Posted: 25 Sep 2016, 15:13
by kooliuypilsa
Same problem here. I have WordPress 4.3.1 and the latest Photonic version and I don't receive any error messages. It is working well for me. All my Picasa images are displaying without any issues.

Re: Photonic Issue on Wordpress 4.3.1

Posted: 25 Oct 2016, 00:19
by ElizabethWilliams
drake wrote:@Semper and @Artie

The current version of WordPress is 4.4.2.

From 4.3.1. to 4.4.2. was a lot of changes. From 4.2.9. to 4.4.2. was even more changes. In this time Photonic itself was updated many times to support the changes from WP and the changes from image providers.
So the current version of Photonic works with the current version of WordPress.

If you have questions related to the current versions please open your own topics.

When update WordPress from such old versions need to take care of many conditions: your theme is updated to support the new version? All plugins are updated? What PHP version is working on your server? Which MySQL version?
Before upgrading make sure that you have a current backup of files and database so you can restore your site if anything goes wrong.
is there a new version of photonic out yet?

Re: Photonic Issue on Wordpress 4.3.1

Posted: 14 Dec 2016, 04:03
by ElizabethWilliams
Semper wrote:
djchr wrote:Dear Aquoid staff,

Thanks for Photonic plugin, I think is the best option to show Picasa images, however recently I updated one of my pages to WP 4.3.1 and the plugin starts to show some issues. I'm desperate right now, I'm getting the following error:

Fatal error: Call to a member function attributes() on a non-object in /home/christia/public_html/ideagro.com/wp-content/plugins/photonic/extensions/Photonic_Picasa_Processor.php on line 269

I did nothing, just only updated Wordpress from 3.9 to 4.3.1, I've been using the plugin since last 3 years on this site with any issue found, all were working properly and amazing until now; it's impossible to show images as before :(

It seems that WP 4.3.1 has been modified which is locking the functionality of Photonic, could you give me please a hand? any ideas?

Thank you!!
Same problem here. I had the Photonic plugin on my old wordpress blog and I just updated to the latest WP and now the plugin isn't working.

I don't want to have to reinstall an old version of wp again. Did you find the fix djchr?

Well i have been using photonic plugin on older version of wp, feeling a bit scared about updating wp will there be a problem?

Re: Photonic Issue on Wordpress 4.3.1

Posted: 17 Dec 2016, 17:20
by ElizabethWilliams
Thanks man, i have been stuck with this issue for quite awhile now. DJ you rock :ugeek:

Re: Photonic Issue on Wordpress 4.3.1

Posted: 12 Feb 2017, 15:06
by sayontan
The OP's issue was resolved quite some time back here: https://wordpress.org/support/topic/fli ... -properly/.

Please note that I no longer support Photonic on this site, but I do it directly on WP: https://wordpress.org/support/plugin/photonic/.