Nov 152012
 

While not Suffusion’s worst release by any stretch (that dishonour goes to version 3.7.4), version 4.4.0 did have some quirks that typically accompany releases that mess around too much with layouts and have been in development for a long but scattered period of time. The currently available version, 4.4.2 should address most of the issues seen:

  1. The worst bug of the lot was one that refused to accept custom image size parameters for images. Luckily the bug was caught within a few hours of the release and I was able to patch it the same evening.
  2. The next bug was the hanging of the tiles layout due to an unresponsive script, which I have taken care of.
  3. The third fix was for a duplicated index of posts in the static featured content. This was a curious bug, which I am not sure that I have rectified fully, mainly because I have not been able to replicate this on my test sites. However I have put in a stopgap fix that will prevent the index from duplicating.
  4. The last fix is again for the tiles layout, where the tiles were appearing too short for their content.

Hopefully this will resolve most of the issues that you have faced after 4.4.0.

  3 Responses to “Suffusion Version 4.4.2”

Comments (3)
  1. Thanks for the update to suffusion – 4.4.2 seems to have partially sorted out the index issue with the featured posts – though I notice when I resize my screen the number of index increases – not sure if this is any help to you in diagnosing the issue further.

    Anyway – i’m really impressed with suffusion – it has really made my little website easier to develop – the site is going to replace http://www.abbeyrunners.co.uk in approx 10 days.

    Mike

     
  2. Sayontan:
    Great job on Suffusion, I have used it on several sites. On one site, I am using V3.8.2 with no troubles. Should I upgrade to V4.4.2? I am not wanting to use responsive, just concerned if there were any security vulnerabilities included in recent updates and therefore should I update or leave as is? Thanks for all you do.
    Doug

     
    • 3.8.2 was released in July 2011. The theme has had several iterations of changes since then, key being the move to HTML5. To the best of my knowledge there weren’t any security vulnerabilities beyond 3.7.3 (which had TimThumb), so you should be good with 3.8.2 from that perspective. Of course, you might want HTML5 and the other goodies that came with the theme over the last one year such as mega menus, custom layout templates etc.

       

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>


*