Upgrade to 3.4.6 wiped everything!

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Locked
covermesongs
Posts: 64
Joined: 27 Mar 2010, 17:16

Upgrade to 3.4.6 wiped everything!

Post by covermesongs » 10 Apr 2010, 11:35

I upgraded automatically to 3.4.6 and it modified every single layout change I had ever made! From three columns to two, from blue-themed to black. Random tabs added, links removed, labels removed. This may be what it looked like at the very beginning...but help!! I've upgraded before with no problem.
Link: http://www.covermesongs.com


covermesongs
Posts: 64
Joined: 27 Mar 2010, 17:16

Re: Upgrade to 3.4.6 wiped everything!

Post by covermesongs » 10 Apr 2010, 11:39

Should have known you'd had it all taken care of. Thanks!

bucks
Posts: 63
Joined: 19 Jan 2010, 16:07

Re: Upgrade to 3.4.6 wiped everything!

Post by bucks » 15 Apr 2010, 15:34

Hi there,
So all of my blog settings were wiped out by the upgrade to 3.4.6.

The instructions provided in the link in your answer above say what to do if your previous version was 3.4.3 or lower.

Actually, in the upgrades area it says:
"DON'T CLICK the button if:

* You are trying out the theme for the first time
* Or you are upgrading from version 3.4.5 or higher

which is exactly what I was doing.

Help?

Thank you,
Buck

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Upgrade to 3.4.6 wiped everything!

Post by sayontan » 15 Apr 2010, 16:30

Are you sure your previous version was 3.4.5? The reason I ask is because 3.4.5 and 3.4.6 were released on subsequent days. If you upgraded from 3.4.3 to 3.4.5, your settings would definitely seem wiped then. Did you do a "migrate" at that point? If you did not do a "migrate" about 1 week back then you never upgraded to 3.4.5.

bucks
Posts: 63
Joined: 19 Jan 2010, 16:07

Re: Upgrade to 3.4.6 wiped everything!

Post by bucks » 15 Apr 2010, 16:38

It has been a few weeks since I last updated the theme. I guess that I figured that the last one I did was 3.4.5 but from what you are saying, maybe i missed it? Today I went to 3.4.6 and the prior update was probably 3 weeks ago. Do you still think it was not 3.4.5? Was there a 3.4.4?

Thanks
Buck

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Upgrade to 3.4.6 wiped everything!

Post by sayontan » 15 Apr 2010, 16:43

I am sure you missed 3.4.5. There was no 3.4.4. I tend to jump to the next multiple of 5 if the changes are big.

Go ahead and execute the Migration script - you will be okay.

bucks
Posts: 63
Joined: 19 Jan 2010, 16:07

Re: Upgrade to 3.4.6 wiped everything!

Post by bucks » 15 Apr 2010, 17:08

Dude. You rock. Seriously.

Now, for future reference...do you have a recommended backing-up/exporting strategy? Should I regularly export from both the theme and from the WP Tools?

Thank you!
Buck

Locked