[suffusion-loginout] shortcode needs parameter?

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Locked
skylar
Posts: 20
Joined: 05 Apr 2012, 22:10

[suffusion-loginout] shortcode needs parameter?

Post by skylar » 06 Jan 2014, 16:17

I think this is a bug I found.
When I use suffusion short codes on my local host, I get the following warning:
Warning: Illegal string offset 'redirect' in E:\xampp\htdocs\wordpress\FCA\wp-content\plugins\suffusion-shortcodes\suffusion-shortcodes.php on line 404
My other site is hosted on Godaddy and doesn't have the problem. So I tried a fresh WordPress install on local host with no plugins except suffusion short codes. But that didn't fix it.

Searching your forums I found that someone else had the same problem on his hosted site but there was no explanation and it fixed itself.
viewtopic.php?f=2&t=29324

Since I know nothing about code, I researched with google and found people discussing this problem with other software. They mostly agreed it had to do with the version of PHP being used. Then I found this
http://wordpress.org/support/topic/incorrect-shortcode
This is a warning, not an error. And the shortcode [nimble-portfolio] is mentioned in this plugin's Description tab (http://wordpress.org/extend/plugins/nim ... scription/)

Shortcode handling function expects template parameter, and if its not there its throughs this warning, you can overcome by providing the template parameter. Use this shortcode instead [nimble-portfolio template="3colround"]
Well, I fixed my problem by using the same parameter

Code: Select all

[suffusion-loginout template="3colround"]
it does seem to be a bug because the solution was to add a parameter :o
But the suffusion short list says there ARE NO parameters... so...that should not fix it -- but it does. I have no idea what template="3colround" is supposed to mean or do.

Thorworx
Posts: 18
Joined: 12 Feb 2013, 03:38

Re: [suffusion-loginout] shortcode needs parameter?

Post by Thorworx » 04 Feb 2014, 09:28

You don't need to use the Suffusion shortcodes plugin. The shortcodes are built-in to suffusion.

I do not have the plugin installed, and I get no errors using the [suffusion-loginout] shortcode on localhost.

User avatar
yehoshanah
Posts: 14
Joined: 21 Dec 2010, 23:27
Location: Byron Bay, Australia
Contact:

Re: [suffusion-loginout] shortcode needs parameter?

Post by yehoshanah » 14 May 2014, 17:05

Yes simply adding a fake parameter worked for me too.
[suffusion-loginout dummy-parameter="to-fix-illegal-string-offset-redirect-warning"]

The shortcode problem occurs when the placement is anywhere on my site.

skylar
Posts: 20
Joined: 05 Apr 2012, 22:10

Re: [suffusion-loginout] shortcode needs parameter?

Post by skylar » 14 May 2014, 18:12

It has to do with the version of PHP.
My godaddy site doesn't require the fake parameter, but the cloned site on the local host does.

I'm glad I posted this because I ended up with the same problem while setting up another site on local host, and I'd forgotten the solution. Googling the error message brought up this post and I quickly fixed it.

Locked