NextGEN Galleries: Error in widgets screen

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Locked
Jovie
Posts: 1
Joined: 04 Jul 2014, 00:55

NextGEN Galleries: Error in widgets screen

Post by Jovie » 04 Jul 2014, 11:28

I am receiving the following error after installing NEXTGEN plus in the plugins panel:

Strict Standards: Declaration of Suffusion_MM_Walker_Edit::start_lvl() should be compatible with Walker_Nav_Menu::start_lvl(&$output, $depth = 0, $args = Array) in /home/nemo/public_html/wp-includes/theme.php on line 1773

Strict Standards: Declaration of Suffusion_MM_Walker_Edit::end_lvl() should be compatible with Walker_Nav_Menu::end_lvl(&$output, $depth = 0, $args = Array) in /home/nemo/public_html/wp-includes/theme.php on line 1773

Strict Standards: Declaration of Suffusion_MM_Walker_Edit::start_el() should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /home/nemo/public_html/wp-includes/theme.php on line 1773

I contacted their support and they referred me to you. I have uninstalled both the basic and plus versions and reinstalled.

In addition to the error codes NextGen will not operate correctly: inputs into editor, several setting screens do not open.

Do I delete the line and reinstall? I do not code but I cut and paste pretty well.


Thank you for your time,
JV

drake
Posts: 6223
Joined: 26 Jul 2011, 07:56
Location: Constanta, Romania
Contact:

Re: NextGEN Galleries: Error in widgets screen

Post by drake » 04 Jul 2014, 12:16

I really doubt that those warnings has something to do with your problems with the plugin. Those warnings refer to Walker_Nav_Menu, so they deal only with the displaying of menus in Suffusion, which works fine. I can't see a reason for Suffusion Walker to interfere in any way with your galleries... And I use NGG on many sites without any problem related to those warnings (they are warnings, not errors, and warnings don't affect the normal functionality). These warning even don't appear with WP_DEBUG activated, they are revealed only by some plugins.

Anyway, you can correct those warnings following the instructions of @dvl from this topic (and from @dvl site): viewtopic.php?f=2&t=24339

But as I said, the problem is not from here, probably you have another plugin incorrectly coded, which break also the functionality of NGG.

Locked