Page 1 of 1

Broken Links

Posted: 12 Mar 2016, 07:53
by wsn
I've just discovered that many of the links on my site are broken and generate the following error message:

Parse error: syntax error, unexpected '[' in /home/content/75/9995875/html/wp-content/themes/suffusion/post-formats/content-gallery.php on line 36

Any ideas?

Thanks.

Re: Broken Links

Posted: 12 Mar 2016, 08:14
by drake
I didn't see this error on any of my sites. This isn't a bug. Is something wrong on your site, but you didn't provide any information for isolating the issue. At least your URL may help us to see what happens: what version of theme you use? what version of WordPress? did you moved the site recently? maybe a plugin conflict with the theme - have you tried to deactivate your plugins to see what happens? have you edited theme or wordpress files? .htaccess file? what PHP version is active on your server? which MySQL version? etc etc etc.

Re: Broken Links

Posted: 12 Mar 2016, 08:48
by wsn
I'm using Wordpress 4.2.2 and Suffusion 4.4.9.
I haven't done anything to the site for a few months and it's been hosted on GoDaddy for years.
I deactivated all of the plugins but the problem remains.
These are just simple links to posts within the site: some work, some don't.
You can see what's happening at recusive.com/universal-wisdom.

Re: Broken Links

Posted: 12 Mar 2016, 09:03
by wsn
I've isolated the problem. The posts that would not display were saved using the Gallery post format rather than the Standard post format.
Don't know if that's Suffusion or Wordpress, but thanks for the reply.