"all in one SEO" plugin title & description issue

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
dzuchara
Posts: 29
Joined: 31 Dec 2009, 14:43
Contact:

"all in one SEO" plugin title & description issue

Post by dzuchara » 25 Nov 2010, 12:49

Hello !

In the theme settings I disabled SEO feature, as I use "all in one SEO" plugin.

BUT blog behaves like I DIDN'T disable that feature...

Here is some example:

1) Title set in the plugin:
1.png
1.png (12.26 KiB) Viewed 6568 times
2) But the title of my blog is:
2.png
2.png (17.94 KiB) Viewed 6568 times
What is different from what I wrote in plugin!

BUT it matches what is in theme (DISABLED!!)
3.png
3.png (45.31 KiB) Viewed 6568 times
The same problem is in PAGES.

Also there is the problem with description. See image in next post!

The description from page content is taken --- not the description of plugin!!

Sorry for my English... I hope I managed to help in some way.

dzuchara
Posts: 29
Joined: 31 Dec 2009, 14:43
Contact:

Re: "all in one SEO" plugin title & description issue

Post by dzuchara » 25 Nov 2010, 12:51

here is 4th image for previous post --- description problem
4.png
4.png (89.77 KiB) Viewed 6567 times

dzuchara
Posts: 29
Joined: 31 Dec 2009, 14:43
Contact:

Re: "all in one SEO" plugin title & description issue

Post by dzuchara » 02 Dec 2010, 05:34

Hello!

Now , when I disable SEO, my pages & posts & homepage don't have TITLE at all!!

Also an issue with "description" exists.

Newest WP & theme versions running.

I can help you figuring out that issue, Skype: dzuchara

M66B
Posts: 13
Joined: 01 Dec 2010, 00:40

Re: "all in one SEO" plugin title & description issue

Post by M66B » 02 Dec 2010, 11:31

I am having the same problem, so if you find a solution/work-around, please post it here.

M66B
Posts: 13
Joined: 01 Dec 2010, 00:40

Re: "all in one SEO" plugin title & description issue

Post by M66B » 02 Dec 2010, 13:11

Is there anything I can do to try to solve this problem?

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: "all in one SEO" plugin title & description issue

Post by sayontan » 02 Dec 2010, 14:22

Open the file actions.php and look for the method suffusion_set_title. You will see this line:

Code: Select all

	if ($suf_seo_enabled != 'enabled') return;
Change it to:

Code: Select all

	if ($suf_seo_enabled != 'enabled') return wp_title('»', false);

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: "all in one SEO" plugin title & description issue

Post by sayontan » 02 Dec 2010, 14:45

@dzuchara,
I don't think the description comes from Suffusion.

M66B
Posts: 13
Joined: 01 Dec 2010, 00:40

Re: "all in one SEO" plugin title & description issue

Post by M66B » 03 Dec 2010, 01:14

I tried the fix, but it is not helping.
My guess is that there is a problem with WordPress 3.0.2.
I choose for disabling all SEO plugins and letting Suffusion rewrite the titles.
Less plugins is always better and faster ...
Last edited by M66B on 03 Dec 2010, 01:23, edited 1 time in total.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: "all in one SEO" plugin title & description issue

Post by sayontan » 03 Dec 2010, 01:17

When you say it is not helping, what is happening? Are you getting a title at all or not?

M66B
Posts: 13
Joined: 01 Dec 2010, 00:40

Re: "all in one SEO" plugin title & description issue

Post by M66B » 03 Dec 2010, 01:25

sayontan wrote:When you say it is not helping, what is happening? Are you getting a title at all or not?
I don't get titles at all, with or without the fix.
BTW, I was using SEO Ultimate instead of All in one SEO.

Locked