Category Posts and Featured Content Widgets

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Dark_Fox28
Posts: 574
Joined: 26 Nov 2009, 08:40
Location: Scotland
Contact:

Category Posts and Featured Content Widgets

Post by Dark_Fox28 » 02 Jul 2011, 10:38

Sorry if already posted.

I just tried both of these right now, category posts will only show the current posts, lets say i select ten to show it will show ten current posts and not show posts from the category selected, unless of course one of the ten latest posts is from that category.

Featured is not cycling through the pics for me, it shows the first picture and then stops and shows blank pages for the rest.

I'm sure someone has already mentioned this and maybe its not a bug but i thought i should post anyways.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Category Posts and Featured Content Widgets

Post by sayontan » 02 Jul 2011, 20:58

Can't replicate the issue with Category posts - every site I have seen it works fine.

I am aware of a problem with the Featured Content, which apparently happens on a "No Sidebars" template for some sites.

Dark_Fox28
Posts: 574
Joined: 26 Nov 2009, 08:40
Location: Scotland
Contact:

Re: Category Posts and Featured Content Widgets

Post by Dark_Fox28 » 03 Jul 2011, 02:47

sayontan wrote:Can't replicate the issue with Category posts - every site I have seen it works fine.

I am aware of a problem with the Featured Content, which apparently happens on a "No Sidebars" template for some sites.
The category posts issue happens when i choose a template for a post, the new feature you added which i love.

Example on this page below, i chose the category dvd blu ray comparisons, it is showing only the latest posts.

http://www.darkrealmfox.com/film_review ... s-charade/

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Category Posts and Featured Content Widgets

Post by sayontan » 03 Jul 2011, 12:21

No, I still cannot replicate that problem locally. My test sites are set up with a single right sidebar default layout. When I switch to a Single Left Sidebar for a particular post, I get no issues with the category posts - I have two widgets and both display their respective categories. I would suspect some sort of caching issues at your end, particularly because I haven't changed any logic within the pulling of the category posts.

Dark_Fox28
Posts: 574
Joined: 26 Nov 2009, 08:40
Location: Scotland
Contact:

Re: Category Posts and Featured Content Widgets

Post by Dark_Fox28 » 03 Jul 2011, 13:20

sayontan wrote:No, I still cannot replicate that problem locally. My test sites are set up with a single right sidebar default layout. When I switch to a Single Left Sidebar for a particular post, I get no issues with the category posts - I have two widgets and both display their respective categories. I would suspect some sort of caching issues at your end, particularly because I haven't changed any logic within the pulling of the category posts.
Caching wouldn't cause the latest posts to show though, that makes no sense since you click the widget and choose the category, caching would just cache whatever category you chose. i deleted browser history and have also purged the W3 cache and still the problem persists, can you try with a no sidebars template and choose the template of left sidebar for one post only and then select a category posts, alternatively you are welcome to check my admin out and see that everything is in order and that indeed there is a problem here.

Edit: just ran another test, switched sidebars in the post to the right side, emptied all caches, went to I.E 9 and flushed the entire history, cookies, temporary files etc etc and the problem persists, also activated a new category posts widget and disabled the old one, selected blu ray screencaps from my site and 15 posts, it is not showing the category and is showing the 15 latest posts, tried switching the featured post widget off and clearing cache, same issue persists.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Category Posts and Featured Content Widgets

Post by sayontan » 03 Jul 2011, 13:40

Caching wouldn't cause the latest posts to show though, that makes no sense since you click the widget and choose the category, caching would just cache whatever category you chose.
No, caching is done per page: a widget might show something on one page and something else on another.

Regardless, I tried your setup and got the same result - no errors in the Category Posts display.

The one other area to look at would be to see if you have a plugin that resets the WP_Query object somewhere.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Category Posts and Featured Content Widgets

Post by sayontan » 03 Jul 2011, 13:41

Also try displaying thumbnails in the category posts to see if a difference is made.

For your other question see this thread: viewtopic.php?f=4&t=5571#p23055. Let me know if it helps.

Dark_Fox28
Posts: 574
Joined: 26 Nov 2009, 08:40
Location: Scotland
Contact:

Re: Category Posts and Featured Content Widgets

Post by Dark_Fox28 » 03 Jul 2011, 13:44

sayontan wrote:
Caching wouldn't cause the latest posts to show though, that makes no sense since you click the widget and choose the category, caching would just cache whatever category you chose.
No, caching is done per page: a widget might show something on one page and something else on another.

Regardless, I tried your setup and got the same result - no errors in the Category Posts display.

The one other area to look at would be to see if you have a plugin that resets the WP_Query object somewhere.
Its the Simply Exclude plugin causing the issue, i deactivated it ( got the right one first time ) and now it picks the correct categories, unfortunately i need Simply Exclude.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: Category Posts and Featured Content Widgets

Post by sayontan » 05 Jul 2011, 09:45

You can try this:
1. Go to widgets/suffusion-category-posts.php
2. Go to the function widget($args, $instance)
3. Towards the end of the function you will see:

Code: Select all

		echo $after_widget;
4. After this, add the following (before "}"):

Code: Select all

		wp_reset_query();
Let me know if it works.

Dark_Fox28
Posts: 574
Joined: 26 Nov 2009, 08:40
Location: Scotland
Contact:

Re: Category Posts and Featured Content Widgets

Post by Dark_Fox28 » 05 Jul 2011, 12:52

sayontan wrote:You can try this:
1. Go to widgets/suffusion-category-posts.php
2. Go to the function widget($args, $instance)
3. Towards the end of the function you will see:

Code: Select all

		echo $after_widget;
4. After this, add the following (before "}"):

Code: Select all

		wp_reset_query();
Let me know if it works.
Just saw this, its getting late here, i'll try this tomorrow and let you know.

Locked