auto-generated excerpt setting ignored in tiles view

Reports about issues that you encounter in Suffusion. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is being officially closed with effect from 3rd February 2019. Future support requests can be posted on the GitHub page at https://github.com/sayontan/suffusion/issues.
Locked
ntslsk
Posts: 21
Joined: 11 Jun 2011, 10:25

auto-generated excerpt setting ignored in tiles view

Post by ntslsk » 10 Aug 2011, 05:46

I changed this setting:

By default auto-generated excerpts in WordPress are 55 words long. You can set this length to anything you like:

[...]

to 10 and to 100, but still the excerpt is ended after 55 words in the category view with tiles layout. The More-tag in the text works however as a work around for shorter excerpts. But I want longer excerpts :)

dglenn99
Posts: 14
Joined: 12 Feb 2010, 17:26

Re: auto-generated excerpt setting ignored

Post by dglenn99 » 11 Aug 2011, 10:15

I'm having difficulty with the Manual excerpts. I can't get it to display the [Read More ...] setting. Nor can I find the <?php the_excerpt(); ?> function referred to by http://codex.wordpress.org/Excerpt to add the recommended code, and if I insert the following code at the end of the functions.php file I get the [Read More ...] prompt, but get a 404 error when selecting the link. I've viewed the functions.php for the excerpt function, found Suffusions version, but hesitate to touch it and make it worse :)

Code: Select all

/**
 *  DRG - Add "Read More" automatically to manual excerpt entries.
 *  8/11/011
 */
function excerpt_read_more_link($output) {
 global $post;
 return $output . '<a href="'. get_permalink($post->ID) . '">  [ Read More... ]</a>';
}
add_filter('the_excerpt', 'excerpt_read_more_link');
Doug

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: auto-generated excerpt setting ignored in tiles view

Post by sayontan » 11 Aug 2011, 13:14

@ntslsk,
I can get it to work without issues by changing the number of words. Are you on a multilingual site using a multilingual plugin? WP's excerpt functionality has some issues with some of these plugins.

@Doug,
That wouldn't be a theme bug. Post your URL and I can take a look.

dglenn99
Posts: 14
Joined: 12 Feb 2010, 17:26

Re: auto-generated excerpt setting ignored in tiles view

Post by dglenn99 » 11 Aug 2011, 19:15

I've worked around it by manually editing the code in the manual excerpt box for now. Since you say it isn't in the theme, then it may be an issue because I am using dyndns to point to my home system while I build the site and demo it for the boss. If it still haunts me after I have moved it to the real site, I will post on the issue again with a URL. It may be a faulty setting on my local Apache server.

Thank you for the response.

ntslsk
Posts: 21
Joined: 11 Jun 2011, 10:25

Re: auto-generated excerpt setting ignored in tiles view

Post by ntslsk » 12 Aug 2011, 07:15

@Sayontan: no I don't have multilangual plugins installed.

I have a workaround though: I'm using manual excerpts now.

Locked