Page 1 of 1

FLuid / Fixed ??

Posted: 20 Dec 2017, 10:39
by Jean Francois
Hi,
I have enabled Response Layouts on my site http://eisentectools.com and am happy with the way the site looks.

In Layouts > Default Sidebar Layout > Widths I have opted for Fluid/Flexible width with 100% width and 1200px max -600px min

However, when browsing on a cellphone and swiping to the left, the content moves and the background without content shows. What am I doing wrong here?

Also, there is a line a the top of the header that stretches from one side to the other. How can I get rid of that?

Thanks
Jean Francois

Re: FLuid / Fixed ??

Posted: 21 Dec 2017, 00:15
by Colin
I can't see anything other than a static page with an image completely filling it. No menu or links to other pages.

Re: FLuid / Fixed ??

Posted: 21 Dec 2017, 01:49
by Jean Francois
Hi Colin,
that's how it's supposed to look :)
It's just a holding page for now.

Apart from the fact that it's just the simple setup with the image, do you also get the swiping issues outlined in my first post?
Thanks

Re: FLuid / Fixed ??

Posted: 21 Dec 2017, 04:17
by Colin
No I don't get the swiping issues in Firefox on Mac.

It may be because you are using srcset on the image remove that and try again. I use CSS and contain or cover with my responsive images and don't have the problem you are experiencing.

Re: FLuid / Fixed ??

Posted: 26 Dec 2017, 11:14
by Jean Francois
Hi Colin,
I hope you enjoyed Xmas!
I took a moment to test my site here: http://mobiletest.me/ and the sliding issue is still alive > http://mobiletest.me/htc_one_emulator/? ... ctools.com

Any ideas on what setting adjustments I can make to stop this? I love the way the site now looks, but this little issue is bugging me
Many thanks
Jean

Re: FLuid / Fixed ??

Posted: 27 Dec 2017, 01:11
by Colin
In your custom CSS you have lots of fixed widths of 1000px I suspect that these are what is causing your issues. Change these to percentages and red the article on setting up for mobiles on Sayontans blog and search this forum for similar issues.

Re: FLuid / Fixed ??

Posted: 28 Dec 2017, 16:58
by mbrsolution
@Jean Francois, I have been reading this thread and I can see a few issues just like @Colin has pointed out. Please read through the following URL http://mbrsolution.com/wordpress/suffus ... ttings.php. It should help you set up your site for responsive viewing.

Let me know if this helps you.

Kind regards