Restore Suffusion Settings

General questions pertaining to how certain issues can be resolved. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.

1. No offensive language and no mocking
2. Please do a thorough search before you post something. Trust us, there is a high probability that the question you are asking has been asked previously.
3. No soliciting. You cannot post here soliciting bids for people offer you quotes, or even offer money to people for some work. You will be moderated if you do so. If you are looking for help, please post your request on http://jobs.wordpress.net or http://codepoet.com
4. Please be reasonable. You are getting software and support. For free. Complicated requests from a general purpose theme are not welcome and some volunteers might lose patience with you.
5. Please do your due diligence. If you posted a query and we answered with a link, take the trouble to go through the link contents.
6. Please post with complete information. Requests for help MUST be accompanied with your URL, particularly if you are asking something like "Why am I seeing a blank space?"
Locked
Andyt8
Posts: 14
Joined: 01 Apr 2012, 22:21

Restore Suffusion Settings

Post by Andyt8 » 18 Jun 2018, 02:33

Hello,

There were an error with my website at https://blackseals.net because of a plugin. Therefore I restored the database with last backup from yesterday. After that, suffusion changed to default settings. I tried to rewrite the settings with phpmyadmin to database, but after reloading of the website, there are back the default settings. What is wrong? The same problem occur if I try to import suffions-options.php. Nothing changes.

Please for help to restore my good old settings.


I use Suffusion 4.5.1 with Wordpress 4.9.6

edit: i tried upgrade to Suffions 4.5.4. After that, restored database - still the same. Tried import of 'suffusion-options.php', which is a little bit older. It imported some settings, but not all. I tried change options with phpmyadmin, but it still don't work.

Andyt8
Posts: 14
Joined: 01 Apr 2012, 22:21

Re: Restore Suffusion Settings

Post by Andyt8 » 18 Jun 2018, 08:06

I started to recreate the most needed settings...

...help is still welcome.

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Restore Suffusion Settings

Post by Colin » 18 Jun 2018, 13:50

All the Suffusion settings are stored in the database so there must be something wrong with your backup/restore process.

Andyt8
Posts: 14
Joined: 01 Apr 2012, 22:21

Re: Restore Suffusion Settings

Post by Andyt8 » 18 Jun 2018, 22:39

Hello Colin, Thank you for your answer.

1) I tried restore with phpmyadmin and mysqldumper. After restoring, I see the correct tables with entries. These entries have the correct information, but suffusion replace it with default settings. It looks like, it is a failure of suffusion.
2) If I still use a sql-script to replace only the entry for suffusion_options, it is saved correctly to database. I'm able to read it again with correct value. However, after a reload of Wordpress, the entry is replaced with default settings of suffusion.
3) After import with suffusion-options.php, there is also settings ignored/replaced after reload of Wordpress.
4) I tried backup and restore with mysqldump. It is also the same failure after first loading of WordPress.

What do you mean in that situation? A problem with backup/restore process or a problem of suffusion reading restored entries?



According to my research, it look like there is maybe a problem with special signs. For example something like that is been used for RSS-Feed name. Don't know if I search in the correct direction?

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Restore Suffusion Settings

Post by Colin » 18 Jun 2018, 23:03

I have no idea of the exact process that you went through. If you had a correct backup and restored it correctly then your setting would have been there. You have complicated matters and possibly messed up the configuration by exporting and importing the settings using the Suffusion export / import option.

IMHO you would be better served by not trying to restore from where you are now and just reconfigure Suffusion.

mbrsolution
Posts: 92
Joined: 01 Jan 2012, 15:58
Location: Australia
Contact:

Re: Restore Suffusion Settings

Post by mbrsolution » 19 Jun 2018, 21:05

Hello @Andyt8, I have written a small tutorial http://mbrsolution.com/themes/how-to-in ... -theme.php for anyone who might need help. This is what I have been doing to update all my sites running Suffusion.

Kind regards

Andyt8
Posts: 14
Joined: 01 Apr 2012, 22:21

Re: Restore Suffusion Settings

Post by Andyt8 » 29 Jun 2018, 02:02

My process for backup and restore is really simple. It work for all execpt of suffusion theme. My backup is correctly and restore was also correctly (same content, length and so on). I'm able to read the tables and get the same entry like before. Wordpress was able to read all tables without problems and show the same content like before (posts, page, ...).

However, it's seems to me the process of reading entries by suffusion theme is a little bit strange. It read the table, ignore them and replace it with standard settings. If I go through suffusion settings and restore all settings (by hand) and read the table, it is the same like before. Not strange?


According to my research, the problem with backup, restore and suffuion theme is maybe some special sign in german or special sign with ASCII Code (for example behind my RSS-Feed name). At the moment I have no time to do further tests, but it look like that is the best way to unterstand this strange situation - and find a solution for the future... - something for later with more time for that.

Locked