Front-office bug

General questions pertaining to how certain issues can be resolved. This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.
Forum rules
This forum is closed with effect from February 2019. Please post future requests on https://github.com/sayontan/suffusion.

1. No offensive language and no mocking
2. Please do a thorough search before you post something. Trust us, there is a high probability that the question you are asking has been asked previously.
3. No soliciting. You cannot post here soliciting bids for people offer you quotes, or even offer money to people for some work. You will be moderated if you do so. If you are looking for help, please post your request on http://jobs.wordpress.net or http://codepoet.com
4. Please be reasonable. You are getting software and support. For free. Complicated requests from a general purpose theme are not welcome and some volunteers might lose patience with you.
5. Please do your due diligence. If you posted a query and we answered with a link, take the trouble to go through the link contents.
6. Please post with complete information. Requests for help MUST be accompanied with your URL, particularly if you are asking something like "Why am I seeing a blank space?"
ventatto
Posts: 5
Joined: 02 Nov 2018, 05:42

Front-office bug

Post by ventatto » 02 Nov 2018, 06:13

Hi,

I have set several settings in Suffusion Options but I have a bug for months now. When I am not connected to the WP-Admin (like a visitor), some settings seem to be forgotten. For example, the main wrapper is not set, the header is displaying once and a half time, the "Aside" way to publish an article doesn't work,...

Does somebody know where the problem comes from ?

Moreover, since yesterday, I've had a navigation bar that appeared above my header while it is set to "hidden" in my Suffusion Options...

Thanks for your help

Here is my website URL : http://www.saintlouisbasket.be

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Front-office bug

Post by Colin » 02 Nov 2018, 07:49

This is not a bug and so I have moved it to the Support Request forum.

Clear your browser cache to see if that helps also clear any caching plugin that you may have.

Your header image is only 967 x 244 but your header is 1000px, I suspect that you have not unset the repeat option for the header.

The top menu should not display if you have not enabled it. Again may well be caching.

Have you recently installed or updated any plugins? If so temporarily disable them and see if that helps.

You are alone with these issues as no one else has reported them and the 20 or so Suffusion sites I manage to don't exhibit any of these problems so it is likely to be something unique to you. A later version of Suffusion is available from this forum so it may well be worth updating Suffusion too.

ventatto
Posts: 5
Joined: 02 Nov 2018, 05:42

Re: Front-office bug

Post by ventatto » 02 Nov 2018, 09:23

I have now clear my browser cache but it doesn't change. The issue is on every visitor's device. When I visit my site while I'm connected to the WP-admin page, all is well displayed ! That's what I can't understand. I don't know what you mean by clearing caching plugin but I don't think it's related to the problem as other users with a different browser see the same "bug" on the website.

I have not recently installed any plugins.

About the later version of Suffusion, it would be nice to download it but how can I add it on my website ? Impossible when I'm in Suffusion options or on the theme details. The only way is to create a ne theme with the .zip I got on the forum but it's written that this theme already exists (I still have 4.4.7 version of Suffusion).

Thanks for your help.

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Front-office bug

Post by Colin » 03 Nov 2018, 00:11

It is your settings in Suffusion that are causing the issue then. As I said your image is not the same size as your header and you don't have repeat turned off. Carefully go through all your header settings.

To install the new version of Suffusion revert to a default theme, delete Suffusion and then add the new zip file via upload then turn Suffusion back on. Suffusion's settings are stored in the database so the config will be preserved.

mbrsolution
Posts: 92
Joined: 01 Jan 2012, 15:58
Location: Australia
Contact:

Re: Front-office bug

Post by mbrsolution » 04 Nov 2018, 14:55

Hi @ventatto, please check the following https://mbrsolution.com/wordpress/add-a ... fusion.php. Let us know if this helps you.

Kind regards

ventatto
Posts: 5
Joined: 02 Nov 2018, 05:42

Re: Front-office bug

Post by ventatto » 04 Nov 2018, 15:20

Yes thanks for this but it was rightly done. I think you don't understand that everything works and is well displayed while I am connected to the wp-admin (because my settings are right). But, mysteriously, it goes wrong when I am not connected anymore (like every visitor actually).

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Front-office bug

Post by Colin » 04 Nov 2018, 23:49

You aren't understanding.

Your header is set to a height of 274px it needs to be set at about 250px. You do not have no-repeat turned on for your header.

You must have changed something as the top navigation is no longer displayed. You need to double check all your settings.

You also seem to have some sort of responsive plugin enabled this is not necessary as Suffusion is responsive, this may be screwing up some of the Suffusion settings.

ventatto
Posts: 5
Joined: 02 Nov 2018, 05:42

Re: Front-office bug

Post by ventatto » 05 Nov 2018, 04:11

I've changed the size of my header like you wanted but of course it obviously change anything. I've never turned off the no-repeat option for my header (see the screenshot). Yes I have changed something for the navigation bar above header but it wasn't the problem I was talking about, this was something else. My useless plugins are all deactivated.

Image

I put there a screenshot of my site when I am connected to the back-office (all works because my Suffusion options are right) and when I am not connected to the back-office (bug with the header, the main wrapper...). If it works when I am connected, it's because the settings are good, but why when I am not connected (and so like a visitor) ?

Image
Image

Colin
Posts: 5066
Joined: 27 Oct 2009, 10:46

Re: Front-office bug

Post by Colin » 05 Nov 2018, 04:44

Try disabling ALL your plugins particularly Jetpack and then check it out.

Something is over-riding what you are setting in the Suffusion backend.

drake
Posts: 6223
Joined: 26 Jul 2011, 07:56
Location: Constanta, Romania
Contact:

Re: Front-office bug

Post by drake » 05 Nov 2018, 18:59

Because you didn't updated the theme to the latest version, before anything else check at Suffusion Options -> Backend -> Site Optimization to have selected "Auto-generate the CSS and print it in the HTML source (Least load on server, ugly page source code)"

This will avoid to load your settings from a cached file.

Because, if you see the page as admin as it should be, but the visitors see another page, the problem can be with the cache. Either you use a caching plugin or a service like cloudflare, either the caching is managed by your server. If you use a caching plugin, go to it's settings and disable everything referring to js or css minification. The minification sounds good in theory but is a pain if is doing automatically, without control.

Finally, I saw that you use a pagebuilder. Start from here, disable that plugin. Page builders either are designed for a specific theme, either for twentyXX themes. These plugins come with their own markup which is hard to believe that will fit in any markup of any theme. So, most likely they will conflict with Suffusion.

With Suffusion don't need pagebuilders. The content can be added directly in Edit post/page screen. Can add there even widgets via Ad-hoc widgets. for anything else you have already a lot of widget areas.

Locked