Page 1 of 1

Error code showing at top of website

Posted: 13 Nov 2018, 06:07
by lucida
Hello,

Any idea on how I can deal with the following error code showing on the website.... I can't seem to access the log-in page as it just shows error codes.

https://www.womenslandarmy.co.uk/overview/

Code: Select all

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Widgets has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-widgets.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Search has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-search.php on line 9 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Follow_Twitter has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-twitter.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Category_Posts has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-query-posts.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Featured_Posts has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-featured-posts.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Google_Translator has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-translator.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Subscription has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-subscription.php on line 20 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Flickr has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-flickr.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Query_Users has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-query-users.php on line 10 Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Suffusion_Child_Pages has a deprecated constructor in /customers/6/a/b/womenslandarmy.co.uk/httpd.www/wp-content/themes/suffusion/widgets/suffusion-child-pages.php on line 10
Thanks

Re: Error code showing at top of website

Posted: 13 Nov 2018, 17:32
by mbrsolution
Hi Lucida, I tested your URL in two different browsers and I didn't see any error messages? I used the following two browsers, Firefox and Google Chrome for the test. Both browsers allowed me to view your site with out any error messages displayed. I also tested the following login forms wp-admin and wp-login and it worked for me. No error messages.

Make sure you clear your browser cache and then carry out another test.

I also would like to point out that this is not a bug. This is related to your computer or laptop.

Let me know if you need more help.

Kind regards

Re: Error code showing at top of website

Posted: 14 Nov 2018, 00:27
by Colin
As @Manuel says this is not a bug and so I have moved it to this forum.

You are running an old version of Suffusion update to the latest version from this forum or from GitHub. It looks like you may be running PHP v7.x and the latest version is compatible with that php version.

I do not see the error message either, have you got error reporting turned on? Try logging out of your admin account and see if you still see the error when you visit the site.

Re: Error code showing at top of website

Posted: 28 Nov 2018, 13:14
by lucida
Thank you for your help everyone, it is much appreciated.
I didn't know I was running the old version...I'll update now.
Thanks