Page 1 of 1

Error code at top

Posted: 01 Dec 2018, 02:43
by kazza
Hi there

Firstly thanks for designing such a great theme - I've had my shop on it for years.

Yesterday my website stopped loading and now I'm getting the following error message

Warning: Declaration of Suffusion_MM_Walker_Edit::start_lvl(&$output) should be compatible with Walker_Nav_Menu::start_lvl(&$output, $depth = 0, $args = Array) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/themes/suffusion/library/suffusion-admin-walkers.php on line 282 Warning: Declaration of Suffusion_MM_Walker_Edit::end_lvl(&$output) should be compatible with Walker_Nav_Menu::end_lvl(&$output, $depth = 0, $args = Array) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/themes/suffusion/library/suffusion-admin-walkers.php on line 282 Warning: Declaration of Suffusion_MM_Walker_Edit::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/themes/suffusion/library/suffusion-admin-walkers.php on line 282 Warning: Cannot modify header information - headers already sent by (output started at /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/themes/suffusion/library/suffusion-admin-walkers.php:282) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-admin/includes/misc.php on line 1126

not sure how to fix it - any ideas?

Thanks
Karen

Re: Error code at top

Posted: 01 Dec 2018, 04:58
by Colin
What did you update before your error?

You are running Suffusion 4.4.6 4.5.4 is available here on the forum and on GitHub so it is worth doing a backup and upgrading to see if that fixes the problem. Are you running php v7.x? If so then you should definitely update Suffusion.

Re: Error code at top

Posted: 05 Dec 2018, 08:23
by kazza
Hi Colin

Thanks for the suggestion - that helped. I've now got the new version of suffusion and my site is working (ish) but jigoshop no longer works with it. I've tried the new jigoshop commerce site but I cant get my products to show up

Re: Error code at top

Posted: 05 Dec 2018, 23:48
by Colin
The new Jigoshop doesn't not work properly with Suffusion even with the Suffusion ecommerce plugin. Revert to the old Jigoshop. See this post viewtopic.php?f=4&t=32684

Re: Error code at top

Posted: 06 Dec 2018, 03:44
by kazza
Thanks Colin

I've tried reactivating the old plugin and it just makes things a lot worse - I get the following error

Warning: Declaration of Jigoshop_Walker_CategoryDropdown::start_el(&$output, $category, $depth, $args) should be compatible with Walker_CategoryDropdown::start_el(&$output, $category, $depth = 0, $args = Array, $id = 0) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/plugins/jigoshop - ks/jigoshop_actions.php on line 947 Warning: Declaration of jigoshop_product_meta_variable::save($parent_id) should be compatible with jigoshop_product_meta::save($post_id, $post) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/plugins/jigoshop - ks/admin/write-panels/product-types/variable.php on line 607 Warning: session_start(): Cannot start session when headers already sent in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/plugins/jigoshop - ks/classes/jigoshop_session.class.php on line 22 Warning: Cannot modify header information - headers already sent by (output started at /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-content/plugins/jigoshop - ks/jigoshop_actions.php:947) in /customers/3/6/8/overallsandboilersuits.co.uk/httpd.www/wp-admin/includes/misc.php on line 1126

Re: Error code at top

Posted: 07 Dec 2018, 00:11
by Colin
Do you have the Suffusion ecommerce plugin installed? If yes then your only choice will be to revert to an earlier backup. You could try a reinstall of Jigoshop and disabling all other plugins to see what happens then.