Page 1 of 1

Borders not shown

Posted: 18 Nov 2015, 05:49
by alawil
I'm trying to get borders around the photos on the following page: ... ulum-week/

The shortcode i am using is:

[gallery type='flickr' user_id='90606220@N04' photoset_id='72157632129287107']

Under Photonic -> Settings -> Flicker -> "In-page" View i have the borders setup in exactly the same way as you see them appearing here: ... o-gallery/

I know this is the settings its using as if i change "How do you want the title of the photos?" it toggle the behavior of the page in question and how the photo titles are displayed.

What am i doing wrong?

Re: Borders not shown

Posted: 18 Nov 2015, 05:57
by alawil
Arh - i just remembered im working on a DEV site by over-riding my local DNS so your not going to see the problem.

With that said are there any known issues with borders for the shortcode im using?

Re: Borders not shown

Posted: 27 Nov 2015, 13:11
by alawil
Hello again, my site is live now, can someone please explain why i don't get a border around the images when i am viewing a single photoset on a page but i do see the boarder when seeing all photosets on a single page or the photos within a photoset in a popup? The links above show the problem?

Re: Borders not shown

Posted: 27 Nov 2015, 13:56
by Colin
They have different CSS classes assigned to the thumbnails that is why the display is different.

You need to add this CSS class to get the border.

Code: Select all

.photonic-flickr-image img, .photonic-picasa-image img, .photonic-500px-image img, .photonic-smug-image img, .photonic-instagram-image img, .photonic-zenfolio-image img {
  border-color: #298ccd;
    border-style: solid;
    border-width: 2px;
    padding: 2px;
This should be added to your custom CSS if your theme has that option or you need to get a CSS plugin and add it there.

Re: Borders not shown

Posted: 30 Nov 2015, 14:19
by alawil
Thanks Colin. That seems to have had the desired effect in terms of adding the border but the padding seems larger. I have tried settings from 1px to 5px none of which seem to effect the actual outcome. Thoughts?

Re: Borders not shown

Posted: 30 Nov 2015, 14:26
by alawil
Also sorry for the delayed response, i did not get an email when you posted but i've solved that problem now!

Re: Borders not shown

Posted: 01 Dec 2015, 00:16
by Colin
You have added the CSS to a core file which is the last thing that you should be doing as it will be overwritten on theme upgrade.

Use a CSS plugin as I suggested.

The problem is that where you have added the padding definition is being ignored as a later style sheet is setting the padding to 5px. If you do what I suggest with the plugin it will sort this out as the plugins CSS will be the last thing added to the page. If you do this then you need to undo your edit to the core css stylesheet.

We recommend you do things in a certain way to avoid issues like this.

Re: Borders not shown

Posted: 01 Dec 2015, 01:54
by alawil
Thanks for taking the time to respond, its appreciated.

Rather than add a CSS plugin i opted for the easy route which was to change the padding to 5 under Photonic\Settings\Flicker\Flicker Photoset Thumbnails (with other Photosets)

This now results in the same padding in both views, with the CSS in my core as i have complete control over it.

Can you please explain why setting the padding under Photonic\Settings\Flicker\Flicker Photoset Thumbnails - "In-page" view for standalone Photoset does not seem to have any effect as from the description it would imply that it should be setting the CSS for me, from what i can determine its a Photonic CSS that is setting the padding to 5?

Re: Borders not shown

Posted: 01 Dec 2015, 02:07
by Colin
No idea I don't actually use the Photonic plugin any more on any of my sites. I am not the plugin author so you will have to see if Sayontan answers.

Make sure you keep a careful note of you CSS changes as you will need to reapply them on theme or plugin update.