SmugMug albums always missing one photo

Reports about issues that you encounter in Photonic.

This forum is not actively monitored. For bug reports please post them to https://wordpress.org/support/plugin/photonic/.
Locked
DrewCH
Posts: 3
Joined: 23 Mar 2012, 04:51

SmugMug albums always missing one photo

Post by DrewCH » 23 Mar 2012, 04:55

I just started using this plugin and it seems to work pretty well, except that for each of my albums, there is always one photo missing. The image count under the album title is correct, but when you click on the thumbnail of the album to view its photos, the last photo is always missing. Is this a known issue? Is there a work-around for this? Any information would be greatly appreciated.

Thanks,
Drew

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: SmugMug albums always missing one photo

Post by sayontan » 23 Mar 2012, 07:00

Seems to work okay on the demo: http://aquoid.com/news/plugins/photonic ... ug-photos/ do you have any specifics for me to test?

DrewCH
Posts: 3
Joined: 23 Mar 2012, 04:51

Re: SmugMug albums always missing one photo

Post by DrewCH » 27 Mar 2012, 14:58

Yea, if you go to the link below and click on the 2nd album, the popup only displays 1 images. If you then click on the album title to go to smugmug, both images are displayed. It seems to work fine for albums that only have 1 image, but any albums with more are missing one. Perhaps it has something to do with the demo loading the specific gallery, instead of clicking the thumbnail of a gallery to navigate to it? Thanks for your help in advance.

http://www.photocumulus.com/?page_id=25

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: SmugMug albums always missing one photo

Post by sayontan » 27 Mar 2012, 15:33

OK, I see what is happening. All photos are getting retrieved, but for some reason the last photo is not being included in the list (it is present as an orphan link in the markup). Let me see how I can fix it.

sayontan
Site Admin
Posts: 10210
Joined: 15 Sep 2009, 16:39
Location: Houston, Texas
Contact:

Re: SmugMug albums always missing one photo

Post by sayontan » 27 Mar 2012, 16:26

OK, I patched this. If you download the latest version (1.21) you should see it working fine.

DrewCH
Posts: 3
Joined: 23 Mar 2012, 04:51

Re: SmugMug albums always missing one photo

Post by DrewCH » 27 Mar 2012, 16:41

Thanks so much!

Locked