Page 1 of 1

Photonic issues when displaying Instagram feed on WordPress

Posted: 05 Jan 2017, 20:31
by Zorglub
I am probably missing something obvious but on my webpage using WordPress 4.7 “Vaughan” I cannot get Photonic to display my Instagram feed.
I tried with the latest versions of the Opera and Firefox browsers on Mac OS Sierra (10.12.2) but to no avail.

Here is a summary of the issues:
In Photonic > Helpers, when I go to the section saying "Instagram ID Finder" Enter your Instagram login id and click "Find," I only get a "Bad Request" result.
My Instagram ID is viahoka and it does exist. See https://www.instagram.com/viahoka/.

On Instagram, I obtained the Client ID and inserted the following text in my webpage:
[gallery type='instagram' view='recent' user_id='xxxxxxxxxxx' thumb_size='150'] (of course, xxxxxxxx is my real Client ID obtained from Instagram's Developer's page https://www.instagram.com/developer/clients/manage/

It only generates an error message, however. It says, "The view parameter has to be defined."

In Photonic > Settings, I also entered the Instagram Client ID.
Nothing gets displayed.

Any help would be appreciated.

Re: Photonic issues when displaying Instagram feed on WordPr

Posted: 06 Jan 2017, 03:47
by Colin
Sorry I don't use Photonic with Instagram only 500px.

Re: Photonic issues when displaying Instagram feed on WordPr

Posted: 10 Jan 2017, 14:46
by sayontan
Instagram changed a lot of things in its API, and I have rewritten Photonic's Instagram API to work with it. However, the new version needs Instagram to approve my API key ... which it hasn't done (See here: https://wordpress.org/support/topic/aut ... instagram/). I will upload a new version that fixes these issues, as soon as Instagram performs its approval.